How-to Install VMware Player / Workstation on 2.6.24 Kernel

Update: If you are looking for patching VMware for Linux 2.6.25 Kernel – check here

Currently latest VMware Player and Workstation do not install under Linux 2.6.24 Kernel. This is a short how-to resolve the gcc/make errors that arise while configuring (vmware-configure.pl)

1. Download the latest vmware player (workstation) – currently VMware Player 2.0.2 Build 59824
url: http://www.vmware.com/download/player/ – Read the Eula before downloading

2. tar xzvf VMware-player-2.0.2-59824.i386.tar.gz

3. cd vmware-player-distrib/

4. ./vmware-install.pl – Proceed as usual when asked to run vmware-config.pl answer NO

5. Download the latest any-any patch – currently vmware-any-any-update-116
url: http://vm…s.googlegroups.com/web/vmware-any-any-update-116.tgz

6. tar xzvf vmware-any-any-update-116.tgz

7. cd vmware-any-any-update116

8. ./runme.pl and when asked to run vmware-config.pl answer YES

9. Configure as usual

10. Enjoy!

PS. Link is broken so I reuploaded on my hosting. Patch is presented as is and I don’t take any responsibility for it. All credits go to the author.

Anyway http://blog.creonfx.com/temp/vmware-any-any-update-116.tgz

Be Sociable, Share!

Tags: , , ,

114 Responses to “How-to Install VMware Player / Workstation on 2.6.24 Kernel”

  1. Anthony Says:

    OK, followed btmorex’s advice, now I have a mess of a machine, lol.

    but before i did, i uninstalled vmware player, “installed” vmware server (using patch), and now, no matter how many times I run runme.pl or vmware-config.pl, vmware -v prints:

    /usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_3.4′ not found (required by /usr/lib/libcairo.so.2)
    /usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0′ not found (required by /usr/lib/libstdc++.so.6)
    /usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_3.4′ not found (required by /usr/lib/libcairo.so.2)
    /usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0′ not found (required by /usr/lib/libstdc++.so.6)
    /usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_3.4′ not found (required by /usr/lib/libcairo.so.2)
    /usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0′ not found (required by /usr/lib/libstdc++.so.6)

    ………
    HELP!!!!!

    A google digs mailing lists discussing the problem, and it traces to system shared library dependencies (what fun). I tried bluntly installing gcc 3.4, and 4.2 is already installed and used to make the thing in the first place. I tried symlinking around libcairo to fix it, but to no avail. like I said, my machine is an utter catastrophe. Any help is greatly appreciated.

  2. Anthony Says:

    nevermind this fixed it

    $ mv /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1 /usr/lib/vmware/lib/libgcc_s.so.1libgcc_s.so.1.old
    $ mv /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0 /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0.old
    $ cp /lib/libgcc_s.so.1 /usr/lib/vmware/lib/libgcc_s.so.1/
    $ cp /usr/lib/libpng12.so.0 /usr/lib/vmware/lib/libpng12.so.0/

    hope that helps

  3. jeepGuy Says:

    This worked as advertised on Ubuntu 8.04 and VMware-player-2.0.4.
    Thanks!

  4. jeepGuy Says:

    Update – close but no cigar:

    Version mismatch with vmmon module: expecting 168.0, got 137.0.

    You have an incorrect version of the `vmmon’ kernel module.
    Try reinstalling VMware Player.

    On the note from Erik – I will try VMware-player-2.0.3 next…

  5. Peter Says:

    @jeepGuy 2.04 ?

    ps. Smooking can break Vmware Player 🙂

  6. Jesper kjeldgaard Says:

    Hi.

    Got this working on hardy with kernel 2.6.24-19.

    thanks

  7. Jacob Dorne Says:

    I didn’t need this on Ubuntu 8.04 with the 2.6.24-19-generic kernel.

    I use VMWare Workstation v6.0.4 build-93057

    The install from vmware-install.pl went fine. Even the configure script. All modules were built and Virtual Machines run perfect.

    One problem though: I get an error when starting a virtual machine because it cannot load the sound driver. Error accessing /dev/dsp
    ???

    Does this guide fix this issue???

  8. Peter Says:

    @Jacob – Your problem is probably due to your sound system.

    1. Do not run any applications that are using sounds (mp3/video players, sites with flash etc)
    2. Be sure you are using alsa or other relevantly new architecture.
    3. Check your sound settings and reduce the time for unlocking the sound device

    generally my suggestion is to boot, not starting any application wait for couple of minutes (if you have startup sounds) and then run vmware workstation

  9. Dirk Weckerlei Says:

    I still haven’t found a solution (even on this page) regarding this error message: Version mismatch with vmmon module: expecting 161.0, got 167.0. What went wrong?
    I installed vmware .v6.0.0.45731 with the 116 patch several times, but still get the same error. Who can help?

  10. Dirk Weckerlei Says:

    Found the solution: Sometimes it helps thinking aloud and consulting google more specific!
    Just copied the files from her: http://download.rhsoft.net/vmware.tar.bz2 and copied them to /usr/lib/vmware/modules/source; then rerun vmware-config.pl. Now it seems to work!!
    If you experience problems contact me via debian_on_ebay*at*yahoo.de

    Regards
    Dirk

  11. Dirk Weckerlei Says:

    Obviously my thread caught some attention .o)
    Unfortunately the provided link (http://download.rhsoft.net/vmware.tar.bz2) is broken. I will upload the needed files and will notify you regarding the new url shortly.

    So long
    dw

  12. Rudi Says:

    VMWare Server 1.0.6 under Ubuntu 8.04 does not need any patch anymore.
    http://howtoforge.com/installing-vmware-server-on-ubuntu-8.04

  13. Ngoc Says:

    Why you don’t use .rpm files. It isn’t difficult??

  14. Peter Says:

    Because I’m using either Debian or Ubuntu/Kubuntu so I prefer deb packages and I’m not a big fan of rpm/alien under Debian

Leave a Reply